Google Outage

Incident Report for Vitally

Resolved

google has closed their incident
Posted Jul 18, 2025 - 18:59 UTC

Identified

Google has identified their incident and will publish updates publicly here: https://status.cloud.google.com/incidents/8cY8jdUpEGGbsSMSQk7J
Posted Jul 18, 2025 - 15:55 UTC

Investigating

We are seeing elevated failure rate of processes depending on Google for SSO login. If you utilize Google SSO to log in to Vitally, you may experience issues in doing so. We are not yet seeing errors in Google for Calendar or Mail syncs and are still waiting for Google to publicly acknowledge this outage but the internet is containing many other reports
Posted Jul 18, 2025 - 15:39 UTC
This incident affected: Product.