Vitally Not Loading
Incident Report for Vitally
Resolved
We have resolved the issue impacting page loads
Posted Apr 22, 2024 - 14:26 UTC
Investigating
We are investigating an issue preventing users from loading the Vitally web app
Posted Apr 22, 2024 - 14:02 UTC
This incident affected: Product.