Elevated Server Response Times

Incident Report for Vitally

Resolved

This incident has been resolved.
Posted Aug 06, 2025 - 22:29 UTC

Update

We are continuing to monitor for any further issues.
Posted Aug 06, 2025 - 14:16 UTC

Monitoring

We've identified the issue and server response times have normalized. Some queues, including formula field calculation and some integrations, are continuing to catch up.
Posted Aug 05, 2025 - 22:04 UTC

Update

We are continuing to investigate the issue.
Playbook execution may be delayed.
Formula field calculation is delayed.
Posted Aug 05, 2025 - 15:33 UTC

Investigating

We are investigating performance issues causing elevated server response times. Playbook execution and formula field calculation is delayed.
Posted Aug 05, 2025 - 11:25 UTC
This incident affected: Product.