Elevated Server Response Times

Incident Report for Vitally

Resolved

This incident has been resolved.
Posted Apr 25, 2025 - 14:19 UTC

Update

We are continuing to investigate this issue.
Posted Apr 24, 2025 - 17:38 UTC

Update

We are continuing to investigate this issue.
Posted Apr 24, 2025 - 16:46 UTC

Update

We are continuing to investigate this issue.
Posted Apr 24, 2025 - 15:48 UTC

Investigating

We are seeing elevated server response times which can result in a slow experience using Vitally. We are investigating the root cause.
Posted Apr 24, 2025 - 14:38 UTC
This incident affected: Product and Analytics Data Processing.