External vitally.io Site Down

Incident Report for Vitally

Resolved

Our vendor has resolved this and the page loads on refresh
Posted Jun 03, 2025 - 18:02 UTC

Identified

Our marketing vendor is experiencing an outage (https://status.webflow.com) which is causing `vitally.io` to not load.

In order to login, you can directly navigate to https://login.vitally.io. No Vitally Product experiences are currently impacted
Posted Jun 03, 2025 - 16:54 UTC