Issues saving Custom Object traits

Incident Report for Vitally

Resolved

The fix has been deployed. Any users still experiencing issues should make sure they have the latest version by refreshing all browser pages.
Posted Nov 14, 2025 - 14:48 UTC

Identified

An issue with saving CustomObject traits has been identified and a fix is being deployed
Posted Nov 13, 2025 - 23:08 UTC
This incident affected: Product.